UPDATE: With the release of version 4.15 on July 19, 2017, commercial Metasploit 32-bit platforms (Metasploit Pro, Metasploit Express, and Metasploit Community) no longer receive future product or content updates. These platforms are now obsolete and are no longer supported.

Rapid7 announced the end of life of Metasploit Pro 32-bit versions for both Windows and Linux operating systems on July 5th, 2017.  This announcement applies to all editions: Metasploit Pro, Metasploit Express and Metasploit Community.  After this date Metasploit 32-bit platforms will not receive product or content updates. Metasploit Framework will continue to provide installers and updates for the 32-bit versions.

Milestone Description Date
End-of-life announcement date The date that the end-of-life date has been announced to the general public. July 5th, 2016
Last date of available installers The last date Rapid7 will generate 32-bit installers. After this date, Rapid7 will continue to provide updates until the last date of support. July 5th, 2016
Last date of support The last date to receive service and support for the product. After this date, all support services for the product are unavailable, and the product becomes obsolete. July 5th, 2017

Product Migrations

Customers are encouraged to migrate to Metasploit 64-bit versions of the product, installation files can be found in the following link.  When upgrading to there maybe changes to system requirements including memory, please view the System requirements to see if your current system meets the minimum requirements.  To migrate to a newer platform you create a platform independent backup and restore it on the new system.  Please see this page to learn how to determine if you need to migrate, how to do a backup/restore, and about other related topics.

More Information