As of April 8th, 2015, version 1.0 of the Nexpose gem (nexpose-client) is available.

Big Numbers Mean Big Changes

Nexpose 5.13 brings new API 2.1 features and following on that the 1.0 version of the Nexpose gem uses these new features. Because of this, the new version of the gem includes some changes that are not backwards compatible with older versions of the gem or Nexpose. A migration guide is available to help you get your scripts and applications that rely on the gem to be compatible with 1.0. Note that upgrading to version 1.0 is not yet required. The 0.9.x versions will continue to work, but the new API features will not be available.

What is required for version 1.0?

With Ruby 1.9 in end-of-life status, we're no longer going to ensure that the gem is compatible. We've settled on Ruby 2.1 as the new minimum version we'll support as it brings some important new features over Ruby 2.0. In order to use version 1.0 of the Nexpose gem, you must be running Ruby 2.1 or later. We recommend version 2.1.5 or 2.2.1 as of this writing.

Nexpose 5.13 is also required to use most of the site related features of the gem.

What changed?

The 1.0 version of the gem includes significant changes to the way you use Sites, Schedules, and Credentials. Many of these changes required breaking backwards compatibility, so this is where the migration guide will come in handy. For a full list of changes, see the release notes on Github.

Old Versions

For those of you who are not ready to migrate your scripts or applications to be 1.0 compatible, you can still use the older versions of the gem for now. Be sure to pin the version in your Gemfile if you expect to be running bundle to install or update gems. Note that we will not provide ongoing support or updates for older versions of the Nexpose gem.

Bugs and Feature Requests

If you run into any bugs when using nexpose-client 1.0 with Nexpose 5.13, please submit an issue on Github. Feature requests for the gem should also be submitted as a Github issue. Pull requests are also apppreciated!

Documentation Updates

Documentation for the gem is an ongoing effort. Check the Github wiki for new and updated pages - note that the wiki can be updated by anyone. You can also find the gem's API documentation on RubyDoc.