With the release of Nexpose 5.9.16, we are also releasing a new version of the gem: 0.8.0

We bumped the version from 0.7 to mark several changes. First, there are two methods that would not work against the new release without some code changes to the gem. These cover searching for vulnerabilities and running ad hoc HTML reports.

But most significant is the addition of the nokogiri (鋸) gemhttps://rubygems.org/gems/nokogirias a dependency. We decided to pull in this dependency because of a parsing issue around the ad hoc HTML reports. If this dependency proves to be a problem, then please let us know. But our testing has shown that nokogiri is handled smoothly in the environments we tested. If the transition proves to be smooth, we may being to use nokogiri more extensively, especially for parsing large, incoming data sets.

For additional details, see the release notes: Changes to the Nexpose Gem in Version 0.8.0