With the release of Nexpose 5.7.10, we have made some great changes to our Vulnerability page. Due to popular demand, you'll now be able to select a set of filters and get a distilled, refined version of the vulnerabilities list for export or exclusion.

Prior to this release, the Vulnerability page would display all of the vulnerabilities found across your network. While useful, a large list of vulnerabilities could be daunting to manage. Now it is possible to narrow the scope of your view to just those vulnerabilities you want to act on.  This amazing new feature allows you to select from a set of initial filters: Site, Asset Groups, Risk Score, and CVSS. After selecting one of these filters, you can drill down to only the set of vulnerabilities that you want to see. Once you've narrowed the scope, you can take subsequent actions like performing exclusions or exporting to a CSV- formatted file. This will improve a lot of workflows, especially integrating with other solutions that take in vulnerability data such as Ticketing Systems, IDS/IPS, and SIEMS.

The set of predetermined filters and functionality is in constant expansion.  PCI compliance filters, saving and reloading a set of filters, exporting them to XML, and many other cool ideas are on our radar.

We love your feedback! To let us know what you think about this new feature, please join the discussion in the Rapid7 Community.